Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Host side USB console utilities" |
| 2 | DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus." |
| 3 | HOMEPAGE = "http://www.linux-usb.org" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 8 | |
| 9 | DEPENDS = "libusb zlib virtual/libiconv" |
| 10 | |
| 11 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \ |
| 12 | file://usb-devices-avoid-dependency-on-bash.patch \ |
| 13 | file://Fix-NULL-pointer-crash.patch \ |
| 14 | file://iconv.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "be6c42294be5c940f208190d3479d50c" |
| 18 | SRC_URI[sha256sum] = "e65c234cadf7c81b6b1567c440e3b9b31b44f51c27df3e45741b88848d8b37d3" |
| 19 | |
| 20 | inherit autotools gettext pkgconfig |
| 21 | |
| 22 | do_install_append() { |
| 23 | # We only need the compressed copy, remove the uncompressed version |
| 24 | rm -f ${D}${datadir}/usb.ids |
| 25 | } |
| 26 | |
| 27 | PACKAGES += "${PN}-ids" |
| 28 | FILES_${PN}-dev += "${datadir}/pkgconfig" |
| 29 | FILES_${PN}-ids = "${datadir}/usb*" |
| 30 | |
| 31 | RDEPENDS_${PN} = "${PN}-ids" |