Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Vulkan Header files and API registry" |
| 2 | DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \ |
| 3 | to modern GPUs with low overhead and targeting realtime graphics applications such as \ |
| 4 | games and interactive media. This package contains the development headers \ |
| 5 | for packages wanting to make use of Vulkan." |
| 6 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 7 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https" |
| 13 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 14 | SRCREV = "9e61870ecbd32514113b467e0a0c46f60ed222c7" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake |
| 19 | |
| 20 | FILES:${PN} += "${datadir}/vulkan" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 21 | RDEPENDS:${PN} += "python3-core" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 23 | # These recipes need to be updated in lockstep with each other: |
| 24 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools |
| 25 | # The tags versions should always be sdk-x.y.z, as this is what |
| 26 | # upstream considers a release. |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 27 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |