Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Framework for defining and tracking users, login sessions, and seats" |
| 2 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ConsoleKit" |
| 3 | BUGTRACKER = "https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit" |
| 4 | |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
| 7 | file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3" |
| 8 | |
| 9 | DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11" |
| 10 | RDEPENDS_${PN} += "base-files" |
| 11 | |
| 12 | inherit autotools pkgconfig distro_features_check |
| 13 | # depends on virtual/libx11 |
| 14 | REQUIRED_DISTRO_FEATURES = "x11" |
| 15 | |
| 16 | SRC_URI = "http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-${PV}.tar.xz \ |
| 17 | file://sepbuildfix.patch \ |
| 18 | file://add-polkit-configure-argument.patch \ |
| 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "611792b4d616253a5bdec9175f8b7678" |
| 22 | SRC_URI[sha256sum] = "b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c" |
| 23 | |
| 24 | S = "${WORKDIR}/ConsoleKit-${PV}" |
| 25 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd polkit', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | |
| 28 | PACKAGECONFIG[pam] = "--enable-pam-module --with-pam-module-dir=${base_libdir}/security,--disable-pam-module,libpam" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--with-systemdsystemunitdir=" |
| 31 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 32 | FILES_${PN} += "${exec_prefix}/lib/ConsoleKit \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 33 | ${libdir}/ConsoleKit ${systemd_unitdir} ${base_libdir} \ |
| 34 | ${datadir}/dbus-1 ${datadir}/PolicyKit ${datadir}/polkit*" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 35 | |
| 36 | PACKAGES =+ "pam-plugin-ck-connector" |
| 37 | FILES_pam-plugin-ck-connector += "${base_libdir}/security/*.so" |
| 38 | RDEPENDS_pam-plugin-ck-connector += "${PN}" |
| 39 | |
| 40 | do_install_append() { |
| 41 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 42 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 43 | echo "d ${localstatedir}/log/ConsoleKit - - - -" \ |
| 44 | > ${D}${sysconfdir}/tmpfiles.d/consolekit.conf |
| 45 | fi |
| 46 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 47 | # Remove /var/ directories as the daemon creates them as required |
| 48 | rm -rf ${D}${localstatedir} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 49 | } |