blob: 9aed0d62e48005c1f07edcbae2710d718ab8d8bc [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
Andrew Geissler5082cc72023-09-11 08:41:39 -04006SRC_URI[sha256sum] = "c9f2a0a85d545e5362e967e4f069f56fddfd91215e22ffa48c66fb283521319a"
Andrew Geissler3eeda902023-05-19 10:14:02 -05007
8inherit pypi python_setuptools_build_meta ptest
9
10DEPENDS += " python3-calver-native"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18 ${PYTHON_PN}-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"