Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Parsec Command Line Interface" |
| 2 | HOMEPAGE = "https://github.com/parallaxsecond/parsec-tool" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
| 6 | inherit cargo cargo-update-recipe-crates |
| 7 | |
| 8 | SRC_URI += "crate://crates.io/parsec-tool/${PV} \ |
| 9 | " |
| 10 | SRC_URI[parsec-tool-0.7.0.sha256sum] = "76afb4416d04c5af9f81285dfff390b09c6926aabd6b4ee20dc07470a9698732" |
| 11 | |
| 12 | B = "${CARGO_VENDORING_DIRECTORY}/${BP}" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}/${bindir} |
| 16 | install -m 755 "${B}/target/${CARGO_TARGET_SUBDIR}/parsec-tool" "${D}${bindir}/parsec-tool" |
| 17 | install -m 755 "${S}/tests/parsec-cli-tests.sh" "${D}${bindir}/parsec-cli-tests.sh" |
| 18 | } |
| 19 | |
| 20 | require parsec-tool-crates.inc |
| 21 | |
| 22 | RDEPENDS:${PN} = "openssl-bin" |
| 23 | |
| 24 | # The QA check has been temporarily disabled. An issue has been created |
| 25 | # upstream to fix this. |
| 26 | # https://github.com/parallaxsecond/parsec-tool/issues/94 |
| 27 | INSANE_SKIP:${PN}-dbg += "buildpaths" |