Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| 8 | |
| 9 | DEPENDS += "python3 glib-2.0" |
| 10 | |
| 11 | SRCNAME="pygobject" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 12 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | SRC_URI = " \ |
| 14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 15 | file://0001-Do-not-build-tests.patch \ |
| 16 | " |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "ebfebc4533856572281add29f08412bf" |
| 18 | SRC_URI[sha256sum] = "d1bf42802d1cec113b5adaa0e7bf7f3745b44521dc2163588d276d5cd61d718f" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
| 20 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
| 21 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| 25 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 26 | RDEPENDS_${PN} += "python3-pkgutil" |
| 27 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 28 | # python3-pycairo is checked on configuration -> DEPENDS |
| 29 | # we don't link against python3-pycairo -> RDEPENDS |
| 30 | PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python3-pycairo, python3-pycairo" |
| 31 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | BBCLASSEXTEND = "native" |
| 33 | PACKAGECONFIG_class-native = "" |