blob: f90ea0c9dc0e0178c1cf19160e0d4ba77a4311c1 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Python module for Semantic Versioning"
2HOMEPAGE = "https://github.com/python-semver/python-semver"
3BUGTRACKER = "https://github.com/python-semver/python-semver"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d9da679db3bdce30a1b4328d5c474f98"
6
7SRC_URI[sha256sum] = "6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc"
8
9inherit pypi python_setuptools_build_meta ptest
10
11BBCLASSEXTEND = "native nativesdk"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17DEPENDS += " python3-setuptools-scm-native"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 cp -rf ${S}/tests ${D}${PTEST_PATH}/
25}