blob: e925712f36adb9b4fb576cd1da904c378e085a59 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "A utility provides a fake certificate authority (CA)"
2HOMEPAGE = "https://pypi.org/project/trustme"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a"
6
7SRC_URI[sha256sum] = "5375ad7fb427074bec956592e0d4ee2a4cf4da68934e1ba4bcf4217126bc45e6"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += " \
16 python3-cryptography \
17 python3-datetime \
18 python3-idna \
19 python3-io \
20"
21
22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24 ${PYTHON_PN}-service-identity \
25 ${PYTHON_PN}-pyasn1-modules \
26"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
32}