blob: 9a136f29788ee49127247babf718ce0b2d24ee0e [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "Simple hello world example"
2HOMEPAGE = "https://github.com/akiernan/hello-bin"
3LICENSE = "Unlicense"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7246f848faa4e9c9fc0ea91122d6e680"
5
6SRC_URI = "git://github.com/akiernan/hello-bin.git;protocol=https;branch=main;subpath=rust \
7 file://0001-Greet-OE-Core.patch \
8 git://github.com/akiernan/hello-lib.git;protocol=https;branch=main;name=hello-lib;destsuffix=hello-lib;type=git-dependency \
9 "
10SRCREV = "d3d096eda182644868f8e7458dcfa538ff637db3"
11
12SRCREV_FORMAT .= "_hello-lib"
13SRCREV_hello-lib = "59c84574e844617043cf337bc8fa537cf87ad8ae"
14
15S = "${WORKDIR}/rust"
16
17inherit cargo cargo-update-recipe-crates ptest-cargo
18
19# Remove this when the recipe is reproducible
20EXCLUDE_FROM_WORLD = "1"
21
22require ${BPN}-crates.inc