Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple hello world example" |
| 2 | HOMEPAGE = "https://github.com/akiernan/hello-bin" |
| 3 | LICENSE = "Unlicense" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7246f848faa4e9c9fc0ea91122d6e680" |
| 5 | |
| 6 | SRC_URI = "git://github.com/akiernan/hello-bin.git;protocol=https;branch=main;subpath=rust \ |
| 7 | file://0001-Greet-OE-Core.patch \ |
| 8 | git://github.com/akiernan/hello-lib.git;protocol=https;branch=main;name=hello-lib;destsuffix=hello-lib;type=git-dependency \ |
| 9 | " |
| 10 | SRCREV = "d3d096eda182644868f8e7458dcfa538ff637db3" |
| 11 | |
| 12 | SRCREV_FORMAT .= "_hello-lib" |
| 13 | SRCREV_hello-lib = "59c84574e844617043cf337bc8fa537cf87ad8ae" |
| 14 | |
| 15 | S = "${WORKDIR}/rust" |
| 16 | |
| 17 | inherit cargo cargo-update-recipe-crates ptest-cargo |
| 18 | |
| 19 | # Remove this when the recipe is reproducible |
| 20 | EXCLUDE_FROM_WORLD = "1" |
| 21 | |
| 22 | require ${BPN}-crates.inc |