Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 1 | SUMMARY = "Extremely fast non-cryptographic hash algorithm" |
| 2 | DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \ |
| 3 | working at speeds close to RAM limits." |
| 4 | HOMEPAGE = "http://www.xxhash.com/" |
| 5 | LICENSE = "BSD-2-Clause & GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b335320506abb0505437e39295e799cb" |
| 7 | |
| 8 | SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=git" |
| 9 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 10 | |
| 11 | SRCREV = "94e5f23e736f2bb67ebdf90727353e65344f9fc0" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | do_compile () { |
| 16 | oe_runmake all |
| 17 | } |
| 18 | |
| 19 | do_install () { |
| 20 | oe_runmake DESTDIR=${D} install |
| 21 | } |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |