Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Vendor Package Management for Golang" |
| 2 | HOMEPAGE = "https://glide.sh" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2" |
| 5 | |
| 6 | GO_IMPORT = "github.com/Masterminds/glide" |
| 7 | SRC_URI = "git://${GO_IMPORT}" |
| 8 | SRCREV = "8ed5b9292379d86c39592a7e6a58eb9c903877cf" |
| 9 | |
| 10 | inherit go |
| 11 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 12 | # New Go versions has Go modules support enabled by default and cause the Glide |
| 13 | # tool build to fail. |
| 14 | export GO111MODULE = "off" |
| 15 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | RDEPENDS_${PN}-dev += "bash" |
| 17 | RDEPENDS_${PN}-ptest += "bash" |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
| 21 | # for x86 ends with textrel in ${PN} |
| 22 | # http://errors.yoctoproject.org/Errors/Details/185631/ |
| 23 | # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel] |
| 24 | INSANE_SKIP_${PN} += "textrel" |
| 25 | |
| 26 | # for aarch64 ends with textrel in ${PN}-ptest |
| 27 | # http://errors.yoctoproject.org/Errors/Details/185633/ |
| 28 | # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text |
| 29 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text |
| 30 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text |
| 31 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text |
| 32 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text |
| 33 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text |
| 34 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text |
| 35 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text |
| 36 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text |
| 37 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text |
| 38 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel] |
| 39 | INSANE_SKIP_${PN}-ptest += "textrel" |
| 40 | |
| 41 | # fails to run task compile_ptest_base on mips |
| 42 | PTEST_ENABLED_mipsarch = "0" |