Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "library and tool to create and burn ISO-9660 images" |
| 2 | HOMEPAGE = "https://libburnia-project.org/" |
| 3 | |
| 4 | LICENSE = "GPL-2.0-or-later" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88 \ |
| 6 | file://COPYRIGHT;md5=43cfe25a7e4a65f722d6253fa0649bb1" |
| 7 | |
| 8 | SRC_URI = "http://files.libburnia-project.org/releases/libisoburn-${PV}.tar.gz" |
| 9 | SRC_URI[sha256sum] = "2d89846d43880f17fa591c53b3bea42ffb803628e4e630c680fc2c9184f79132" |
| 10 | |
| 11 | DEPENDS = "libisofs libburn" |
| 12 | # This replaces the xorriso recipe |
| 13 | PROVIDES += "xorriso" |
| 14 | |
| 15 | inherit autotools pkgconfig |
| 16 | |
| 17 | EXTRA_OECONF = "--enable-pkg-check-modules" |
| 18 | |
| 19 | do_install:append() { |
| 20 | # This is a proof-of-concept UI using Tk, don't ship it |
| 21 | rm -f ${D}${bindir}/xorriso-tcltk |
| 22 | } |
| 23 | |
| 24 | PACKAGE_BEFORE_PN = "xorriso" |
| 25 | FILES:xorriso = "${bindir}" |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |