blob: f263b5135022f2f4a374ec706a0ab8ce7dbf2d31 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "library and tool to create and burn ISO-9660 images"
2HOMEPAGE = "https://libburnia-project.org/"
3
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88 \
6 file://COPYRIGHT;md5=43cfe25a7e4a65f722d6253fa0649bb1"
7
8SRC_URI = "http://files.libburnia-project.org/releases/libisoburn-${PV}.tar.gz"
9SRC_URI[sha256sum] = "2d89846d43880f17fa591c53b3bea42ffb803628e4e630c680fc2c9184f79132"
10
11DEPENDS = "libisofs libburn"
12# This replaces the xorriso recipe
13PROVIDES += "xorriso"
14
15inherit autotools pkgconfig
16
17EXTRA_OECONF = "--enable-pkg-check-modules"
18
19do_install:append() {
20 # This is a proof-of-concept UI using Tk, don't ship it
21 rm -f ${D}${bindir}/xorriso-tcltk
22}
23
24PACKAGE_BEFORE_PN = "xorriso"
25FILES:xorriso = "${bindir}"
26
27BBCLASSEXTEND = "native"