Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Portable Hardware Locality (hwloc) software package" |
| 2 | DESCRIPTION = "The Portable Hardware Locality (hwloc) software package \ |
| 3 | provides a portable abstraction of the hierarchical topology of modern \ |
| 4 | architectures." |
| 5 | HOMEPAGE = "https://www.open-mpi.org/software/hwloc/" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=3282e20dc3cec311deda3c6d4b1f990b" |
| 9 | |
| 10 | SRC_URI = "https://www.open-mpi.org/software/${PN}/v1.11/downloads/${BP}.tar.bz2" |
| 11 | SRC_URI[md5sum] = "96c34136ff416d2b13a7821c27477bed" |
| 12 | SRC_URI[sha256sum] = "95d80286dfe658a3f79e2ac90698782bb36e5504f4bac1bba2394ba14dbbad24" |
| 13 | |
| 14 | inherit autotools pkgconfig |
| 15 | |
| 16 | DEPENDS += "ncurses udev zlib" |
| 17 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}" |
| 18 | |
| 19 | PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" |
| 20 | |
| 21 | PACKAGECONFIG[numactl] = "--enable-libnuma,--disable-libnuma,numactl,numactl" |
| 22 | PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2" |
| 23 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo" |
| 24 | PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess" |
| 25 | |
| 26 | # Split hwloc library into separate subpackage |
| 27 | PACKAGES_prepend = " libhwloc " |
| 28 | FILES_libhwloc += "${libdir}/libhwloc.so.*" |
| 29 | RDEPENDS_${PN} += "libhwloc (= ${EXTENDPKGV})" |