Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "USB CEC Adaptor communication Library" |
| 2 | HOMEPAGE = "http://libcec.pulse-eight.com/" |
| 3 | |
| 4 | LICENSE = "GPLv2+" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | DEPENDS = "p8platform udev lockdev ncurses swig-native python3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" |
| 10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | PV = "4.0.1+gitr${SRCPV}" |
| 13 | |
| 14 | SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df" |
| 15 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git \ |
| 16 | file://python-install-location.patch" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | inherit cmake pkgconfig |
| 21 | |
| 22 | # Create the wrapper for python3 |
| 23 | PACKAGES += "python3-${BPN}" |
| 24 | FILES_python3-${BPN} = "${libdir}/python3*" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | |
| 26 | # cec-client and xbmc need the .so present to work :( |
| 27 | FILES_${PN} += "${libdir}/*.so" |
| 28 | INSANE_SKIP_${PN} = "dev-so" |
| 29 | |
| 30 | # Adapter shows up as a CDC-ACM device |
| 31 | RRECOMMENDS_${PN} = "kernel-module-cdc-acm" |