Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "A small Python module for determining appropriate platform-specific dirs" |
| 2 | HOMEPAGE = "https://github.com/platformdirs/platformdirs" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \ |
| 8 | file://run-ptest \ |
| 9 | " |
| 10 | |
| 11 | SRCREV ?= "b8c42ddca4def1fba38b9815a7d94ec2ac630b29" |
| 12 | SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335" |
| 13 | |
| 14 | inherit python_setuptools_build_meta ptest |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | python3-hatch-vcs-native \ |
| 18 | python3-setuptools-scm-native \ |
| 19 | python3-toml-native \ |
| 20 | " |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | RDEPENDS:${PN}-ptest += " \ |
| 25 | ${PYTHON_PN}-appdirs \ |
| 26 | ${PYTHON_PN}-pytest \ |
| 27 | ${PYTHON_PN}-pytest-mock \ |
| 28 | " |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH}/Tests |
| 32 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native" |