Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright 2006-2008 OpenedHand Ltd. |
| 3 | # |
| 4 | |
| 5 | inherit package |
| 6 | |
| 7 | IMAGE_PKGTYPE ?= "deb" |
| 8 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | DPKG_ARCH ?= "${@debian_arch_map(d.getVar('TARGET_ARCH', True), d.getVar('TUNE_FEATURES', True))}" |
| 10 | DPKG_ARCH[vardepvalue] = "${DPKG_ARCH}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | PKGWRITEDIRDEB = "${WORKDIR}/deploy-debs" |
| 13 | |
| 14 | APTCONF_TARGET = "${WORKDIR}" |
| 15 | |
| 16 | APT_ARGS = "${@['', '--no-install-recommends'][d.getVar("NO_RECOMMENDATIONS", True) == "1"]}" |
| 17 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 18 | def debian_arch_map(arch, tune): |
| 19 | tune_features = tune.split() |
| 20 | if arch in ["i586", "i686"]: |
| 21 | return "i386" |
| 22 | if arch == "x86_64": |
| 23 | if "mx32" in tune_features: |
| 24 | return "x32" |
| 25 | return "amd64" |
| 26 | if arch.startswith("mips"): |
| 27 | endian = ["el", ""]["bigendian" in tune_features] |
| 28 | if "n64" in tune_features: |
| 29 | return "mips64" + endian |
| 30 | if "n32" in tune_features: |
| 31 | return "mipsn32" + endian |
| 32 | return "mips" + endian |
| 33 | if arch == "powerpc": |
| 34 | return arch + ["", "spe"]["spe" in tune_features] |
| 35 | if arch == "aarch64": |
| 36 | return "arm64" |
| 37 | if arch == "arm": |
| 38 | return arch + ["el", "hf"]["callconvention-hard" in tune_features] |
| 39 | return arch |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | # |
| 41 | # install a bunch of packages using apt |
| 42 | # the following shell variables needs to be set before calling this func: |
| 43 | # INSTALL_ROOTFS_DEB - install root dir |
| 44 | # INSTALL_BASEARCH_DEB - install base architecutre |
| 45 | # INSTALL_ARCHS_DEB - list of available archs |
| 46 | # INSTALL_PACKAGES_NORMAL_DEB - packages to be installed |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 47 | # INSTALL_PACKAGES_ATTEMPTONLY_DEB - packages attempted to be installed only |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | # INSTALL_PACKAGES_LINGUAS_DEB - additional packages for uclibc |
| 49 | # INSTALL_TASK_DEB - task name |
| 50 | |
| 51 | python do_package_deb () { |
| 52 | import re, copy |
| 53 | import textwrap |
| 54 | import subprocess |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 55 | import collections |
| 56 | |
| 57 | oldcwd = os.getcwd() |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 58 | |
| 59 | workdir = d.getVar('WORKDIR', True) |
| 60 | if not workdir: |
| 61 | bb.error("WORKDIR not defined, unable to package") |
| 62 | return |
| 63 | |
| 64 | outdir = d.getVar('PKGWRITEDIRDEB', True) |
| 65 | if not outdir: |
| 66 | bb.error("PKGWRITEDIRDEB not defined, unable to package") |
| 67 | return |
| 68 | |
| 69 | packages = d.getVar('PACKAGES', True) |
| 70 | if not packages: |
| 71 | bb.debug(1, "PACKAGES not defined, nothing to package") |
| 72 | return |
| 73 | |
| 74 | tmpdir = d.getVar('TMPDIR', True) |
| 75 | |
| 76 | if os.access(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"),os.R_OK): |
| 77 | os.unlink(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN")) |
| 78 | |
| 79 | if packages == []: |
| 80 | bb.debug(1, "No packages; nothing to do") |
| 81 | return |
| 82 | |
| 83 | pkgdest = d.getVar('PKGDEST', True) |
| 84 | |
| 85 | def cleanupcontrol(root): |
| 86 | for p in ['CONTROL', 'DEBIAN']: |
| 87 | p = os.path.join(root, p) |
| 88 | if os.path.exists(p): |
| 89 | bb.utils.prunedir(p) |
| 90 | |
| 91 | for pkg in packages.split(): |
| 92 | localdata = bb.data.createCopy(d) |
| 93 | root = "%s/%s" % (pkgdest, pkg) |
| 94 | |
| 95 | lf = bb.utils.lockfile(root + ".lock") |
| 96 | |
| 97 | localdata.setVar('ROOT', '') |
| 98 | localdata.setVar('ROOT_%s' % pkg, root) |
| 99 | pkgname = localdata.getVar('PKG_%s' % pkg, True) |
| 100 | if not pkgname: |
| 101 | pkgname = pkg |
| 102 | localdata.setVar('PKG', pkgname) |
| 103 | |
| 104 | localdata.setVar('OVERRIDES', d.getVar("OVERRIDES", False) + ":" + pkg) |
| 105 | |
| 106 | bb.data.update_data(localdata) |
| 107 | basedir = os.path.join(os.path.dirname(root)) |
| 108 | |
| 109 | pkgoutdir = os.path.join(outdir, localdata.getVar('PACKAGE_ARCH', True)) |
| 110 | bb.utils.mkdirhier(pkgoutdir) |
| 111 | |
| 112 | os.chdir(root) |
| 113 | cleanupcontrol(root) |
| 114 | from glob import glob |
| 115 | g = glob('*') |
| 116 | if not g and localdata.getVar('ALLOW_EMPTY', False) != "1": |
| 117 | bb.note("Not creating empty archive for %s-%s-%s" % (pkg, localdata.getVar('PKGV', True), localdata.getVar('PKGR', True))) |
| 118 | bb.utils.unlockfile(lf) |
| 119 | continue |
| 120 | |
| 121 | controldir = os.path.join(root, 'DEBIAN') |
| 122 | bb.utils.mkdirhier(controldir) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 123 | os.chmod(controldir, 0o755) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 124 | try: |
| 125 | import codecs |
| 126 | ctrlfile = codecs.open(os.path.join(controldir, 'control'), 'w', 'utf-8') |
| 127 | except OSError: |
| 128 | bb.utils.unlockfile(lf) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 129 | bb.fatal("unable to open control file for writing") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 130 | |
| 131 | fields = [] |
| 132 | pe = d.getVar('PKGE', True) |
| 133 | if pe and int(pe) > 0: |
| 134 | fields.append(["Version: %s:%s-%s\n", ['PKGE', 'PKGV', 'PKGR']]) |
| 135 | else: |
| 136 | fields.append(["Version: %s-%s\n", ['PKGV', 'PKGR']]) |
| 137 | fields.append(["Description: %s\n", ['DESCRIPTION']]) |
| 138 | fields.append(["Section: %s\n", ['SECTION']]) |
| 139 | fields.append(["Priority: %s\n", ['PRIORITY']]) |
| 140 | fields.append(["Maintainer: %s\n", ['MAINTAINER']]) |
| 141 | fields.append(["Architecture: %s\n", ['DPKG_ARCH']]) |
| 142 | fields.append(["OE: %s\n", ['PN']]) |
| 143 | fields.append(["PackageArch: %s\n", ['PACKAGE_ARCH']]) |
| 144 | if d.getVar('HOMEPAGE', True): |
| 145 | fields.append(["Homepage: %s\n", ['HOMEPAGE']]) |
| 146 | |
| 147 | # Package, Version, Maintainer, Description - mandatory |
| 148 | # Section, Priority, Essential, Architecture, Source, Depends, Pre-Depends, Recommends, Suggests, Conflicts, Replaces, Provides - Optional |
| 149 | |
| 150 | |
| 151 | def pullData(l, d): |
| 152 | l2 = [] |
| 153 | for i in l: |
| 154 | data = d.getVar(i, True) |
| 155 | if data is None: |
| 156 | raise KeyError(f) |
| 157 | if i == 'DPKG_ARCH' and d.getVar('PACKAGE_ARCH', True) == 'all': |
| 158 | data = 'all' |
| 159 | elif i == 'PACKAGE_ARCH' or i == 'DPKG_ARCH': |
| 160 | # The params in deb package control don't allow character |
| 161 | # `_', so change the arch's `_' to `-'. Such as `x86_64' |
| 162 | # -->`x86-64' |
| 163 | data = data.replace('_', '-') |
| 164 | l2.append(data) |
| 165 | return l2 |
| 166 | |
| 167 | ctrlfile.write("Package: %s\n" % pkgname) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 168 | if d.getVar('PACKAGE_ARCH', True) == "all": |
| 169 | ctrlfile.write("Multi-Arch: foreign\n") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 170 | # check for required fields |
| 171 | try: |
| 172 | for (c, fs) in fields: |
| 173 | for f in fs: |
| 174 | if localdata.getVar(f, False) is None: |
| 175 | raise KeyError(f) |
| 176 | # Special behavior for description... |
| 177 | if 'DESCRIPTION' in fs: |
| 178 | summary = localdata.getVar('SUMMARY', True) or localdata.getVar('DESCRIPTION', True) or "." |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 179 | ctrlfile.write('Description: %s\n' % summary) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 180 | description = localdata.getVar('DESCRIPTION', True) or "." |
| 181 | description = textwrap.dedent(description).strip() |
| 182 | if '\\n' in description: |
| 183 | # Manually indent |
| 184 | for t in description.split('\\n'): |
| 185 | # We don't limit the width when manually indent, but we do |
| 186 | # need the textwrap.fill() to set the initial_indent and |
| 187 | # subsequent_indent, so set a large width |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 188 | ctrlfile.write('%s\n' % textwrap.fill(t, width=100000, initial_indent=' ', subsequent_indent=' ')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 189 | else: |
| 190 | # Auto indent |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 191 | ctrlfile.write('%s\n' % textwrap.fill(description.strip(), width=74, initial_indent=' ', subsequent_indent=' ')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 192 | |
| 193 | else: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 194 | ctrlfile.write(c % tuple(pullData(fs, localdata))) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 195 | except KeyError: |
| 196 | import sys |
| 197 | (type, value, traceback) = sys.exc_info() |
| 198 | bb.utils.unlockfile(lf) |
| 199 | ctrlfile.close() |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 200 | bb.fatal("Missing field for deb generation: %s" % value) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 201 | |
| 202 | # more fields |
| 203 | |
| 204 | custom_fields_chunk = get_package_additional_metadata("deb", localdata) |
| 205 | if custom_fields_chunk is not None: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 206 | ctrlfile.write(custom_fields_chunk) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 207 | ctrlfile.write("\n") |
| 208 | |
| 209 | mapping_rename_hook(localdata) |
| 210 | |
| 211 | def debian_cmp_remap(var): |
| 212 | # dpkg does not allow for '(' or ')' in a dependency name |
| 213 | # replace these instances with '__' and '__' |
| 214 | # |
| 215 | # In debian '>' and '<' do not mean what it appears they mean |
| 216 | # '<' = less or equal |
| 217 | # '>' = greater or equal |
| 218 | # adjust these to the '<<' and '>>' equivalents |
| 219 | # |
| 220 | for dep in var: |
| 221 | if '(' in dep: |
| 222 | newdep = dep.replace('(', '__') |
| 223 | newdep = newdep.replace(')', '__') |
| 224 | if newdep != dep: |
| 225 | var[newdep] = var[dep] |
| 226 | del var[dep] |
| 227 | for dep in var: |
| 228 | for i, v in enumerate(var[dep]): |
| 229 | if (v or "").startswith("< "): |
| 230 | var[dep][i] = var[dep][i].replace("< ", "<< ") |
| 231 | elif (v or "").startswith("> "): |
| 232 | var[dep][i] = var[dep][i].replace("> ", ">> ") |
| 233 | |
| 234 | rdepends = bb.utils.explode_dep_versions2(localdata.getVar("RDEPENDS", True) or "") |
| 235 | debian_cmp_remap(rdepends) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 236 | for dep in list(rdepends.keys()): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 237 | if dep == pkg: |
| 238 | del rdepends[dep] |
| 239 | continue |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 240 | if '*' in dep: |
| 241 | del rdepends[dep] |
| 242 | rrecommends = bb.utils.explode_dep_versions2(localdata.getVar("RRECOMMENDS", True) or "") |
| 243 | debian_cmp_remap(rrecommends) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 244 | for dep in list(rrecommends.keys()): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 245 | if '*' in dep: |
| 246 | del rrecommends[dep] |
| 247 | rsuggests = bb.utils.explode_dep_versions2(localdata.getVar("RSUGGESTS", True) or "") |
| 248 | debian_cmp_remap(rsuggests) |
| 249 | # Deliberately drop version information here, not wanted/supported by deb |
| 250 | rprovides = dict.fromkeys(bb.utils.explode_dep_versions2(localdata.getVar("RPROVIDES", True) or ""), []) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 251 | rprovides = collections.OrderedDict(sorted(rprovides.items(), key=lambda x: x[0])) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 252 | debian_cmp_remap(rprovides) |
| 253 | rreplaces = bb.utils.explode_dep_versions2(localdata.getVar("RREPLACES", True) or "") |
| 254 | debian_cmp_remap(rreplaces) |
| 255 | rconflicts = bb.utils.explode_dep_versions2(localdata.getVar("RCONFLICTS", True) or "") |
| 256 | debian_cmp_remap(rconflicts) |
| 257 | if rdepends: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 258 | ctrlfile.write("Depends: %s\n" % bb.utils.join_deps(rdepends)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 259 | if rsuggests: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 260 | ctrlfile.write("Suggests: %s\n" % bb.utils.join_deps(rsuggests)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 261 | if rrecommends: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 262 | ctrlfile.write("Recommends: %s\n" % bb.utils.join_deps(rrecommends)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 263 | if rprovides: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 264 | ctrlfile.write("Provides: %s\n" % bb.utils.join_deps(rprovides)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 265 | if rreplaces: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 266 | ctrlfile.write("Replaces: %s\n" % bb.utils.join_deps(rreplaces)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 267 | if rconflicts: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 268 | ctrlfile.write("Conflicts: %s\n" % bb.utils.join_deps(rconflicts)) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 269 | ctrlfile.close() |
| 270 | |
| 271 | for script in ["preinst", "postinst", "prerm", "postrm"]: |
| 272 | scriptvar = localdata.getVar('pkg_%s' % script, True) |
| 273 | if not scriptvar: |
| 274 | continue |
| 275 | scriptvar = scriptvar.strip() |
| 276 | try: |
| 277 | scriptfile = open(os.path.join(controldir, script), 'w') |
| 278 | except OSError: |
| 279 | bb.utils.unlockfile(lf) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 280 | bb.fatal("unable to open %s script file for writing" % script) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 281 | |
| 282 | if scriptvar.startswith("#!"): |
| 283 | pos = scriptvar.find("\n") + 1 |
| 284 | scriptfile.write(scriptvar[:pos]) |
| 285 | else: |
| 286 | pos = 0 |
| 287 | scriptfile.write("#!/bin/sh\n") |
| 288 | |
| 289 | # Prevent the prerm/postrm scripts from being run during an upgrade |
| 290 | if script in ('prerm', 'postrm'): |
| 291 | scriptfile.write('[ "$1" != "upgrade" ] || exit 0\n') |
| 292 | |
| 293 | scriptfile.write(scriptvar[pos:]) |
| 294 | scriptfile.write('\n') |
| 295 | scriptfile.close() |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 296 | os.chmod(os.path.join(controldir, script), 0o755) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 297 | |
| 298 | conffiles_str = ' '.join(get_conffiles(pkg, d)) |
| 299 | if conffiles_str: |
| 300 | try: |
| 301 | conffiles = open(os.path.join(controldir, 'conffiles'), 'w') |
| 302 | except OSError: |
| 303 | bb.utils.unlockfile(lf) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 304 | bb.fatal("unable to open conffiles for writing") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 305 | for f in conffiles_str.split(): |
| 306 | if os.path.exists(oe.path.join(root, f)): |
| 307 | conffiles.write('%s\n' % f) |
| 308 | conffiles.close() |
| 309 | |
| 310 | os.chdir(basedir) |
| 311 | ret = subprocess.call("PATH=\"%s\" dpkg-deb -b %s %s" % (localdata.getVar("PATH", True), root, pkgoutdir), shell=True) |
| 312 | if ret != 0: |
| 313 | bb.utils.unlockfile(lf) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 314 | bb.fatal("dpkg-deb execution failed") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 315 | |
| 316 | cleanupcontrol(root) |
| 317 | bb.utils.unlockfile(lf) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 318 | os.chdir(oldcwd) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 319 | } |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 320 | # Indirect references to these vars |
| 321 | do_package_write_deb[vardeps] += "PKGV PKGR PKGV DESCRIPTION SECTION PRIORITY MAINTAINER DPKG_ARCH PN HOMEPAGE" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 322 | # Otherwise allarch packages may change depending on override configuration |
| 323 | do_package_deb[vardepsexclude] = "OVERRIDES" |
| 324 | |
| 325 | |
| 326 | SSTATETASKS += "do_package_write_deb" |
| 327 | do_package_write_deb[sstate-inputdirs] = "${PKGWRITEDIRDEB}" |
| 328 | do_package_write_deb[sstate-outputdirs] = "${DEPLOY_DIR_DEB}" |
| 329 | |
| 330 | python do_package_write_deb_setscene () { |
| 331 | tmpdir = d.getVar('TMPDIR', True) |
| 332 | |
| 333 | if os.access(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"),os.R_OK): |
| 334 | os.unlink(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN")) |
| 335 | |
| 336 | sstate_setscene(d) |
| 337 | } |
| 338 | addtask do_package_write_deb_setscene |
| 339 | |
| 340 | python () { |
| 341 | if d.getVar('PACKAGES', True) != '': |
| 342 | deps = ' dpkg-native:do_populate_sysroot virtual/fakeroot-native:do_populate_sysroot' |
| 343 | d.appendVarFlag('do_package_write_deb', 'depends', deps) |
| 344 | d.setVarFlag('do_package_write_deb', 'fakeroot', "1") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 345 | } |
| 346 | |
| 347 | python do_package_write_deb () { |
| 348 | bb.build.exec_func("read_subpackage_metadata", d) |
| 349 | bb.build.exec_func("do_package_deb", d) |
| 350 | } |
| 351 | do_package_write_deb[dirs] = "${PKGWRITEDIRDEB}" |
| 352 | do_package_write_deb[cleandirs] = "${PKGWRITEDIRDEB}" |
| 353 | do_package_write_deb[umask] = "022" |
| 354 | addtask package_write_deb after do_packagedata do_package |
| 355 | |
| 356 | |
| 357 | PACKAGEINDEXDEPS += "dpkg-native:do_populate_sysroot" |
| 358 | PACKAGEINDEXDEPS += "apt-native:do_populate_sysroot" |
| 359 | |
| 360 | do_build[recrdeptask] += "do_package_write_deb" |