Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A library for property-based testing" |
| 2 | HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python" |
| 3 | LICENSE = "MPL-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c" |
| 5 | |
| 6 | PYPI_PACKAGE = "hypothesis" |
| 7 | |
| 8 | inherit pypi setuptools3 ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | file://test_binary_search.py \ |
| 13 | file://test_rle.py \ |
| 14 | " |
| 15 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "edc8f984dba5d1b69a6a4564246b7850fa7ec351d2b27c9e7a43c91deab8d45c" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 17 | |
| 18 | RDEPENDS:${PN} += " \ |
| 19 | python3-attrs \ |
| 20 | python3-compression \ |
| 21 | python3-core \ |
| 22 | python3-json \ |
| 23 | python3-pytest \ |
| 24 | python3-sortedcontainers \ |
| 25 | python3-statistics \ |
| 26 | python3-unittest \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 30 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | do_install_ptest() { |
| 34 | install -d ${D}${PTEST_PATH}/examples |
| 35 | install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/ |
| 36 | install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/ |
| 37 | } |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |