blob: a02ff4a4da64d75e962c85dd08cbd93a58dbce50 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "JSON C++ lib used to read and write json file."
2DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
3 and writer in C++. JSON (JavaScript Object Notation) is a \
4 lightweight data-interchange format. It is easy for humans to \
5 read and write. It is easy for machines to parse and generate."
6
7HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
8
9SECTION = "libs"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
13
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050014PE = "1"
15
Andrew Geissler32b11992021-03-31 13:37:05 -050016SRCREV = "9059f5cad030ba11d37818847443a53918c327b1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017SRC_URI = "git://github.com/open-source-parsers/jsoncpp"
18
19S = "${WORKDIR}/git"
20
21inherit cmake
22
Andrew Geissler32b11992021-03-31 13:37:05 -050023EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DBUILD_OBJECT_LIBS=OFF -DJSONCPP_WITH_TESTS=OFF"
Brad Bishopc342db32019-05-15 21:57:59 -040024
25BBCLASSEXTEND = "native"