Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| 6 | |
| 7 | DEPENDS += "python3 python3-setuptools-native" |
| 8 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960" |
| 10 | SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | |
| 12 | inherit pypi distutils3 |
| 13 | |
| 14 | do_install_append() { |
| 15 | # Install as pip3 and leave pip2 as default |
| 16 | rm ${D}/${bindir}/pip |
| 17 | } |
| 18 | |
| 19 | RDEPENDS_${PN} = "\ |
| 20 | python3-compile \ |
| 21 | python3-io \ |
| 22 | python3-html \ |
| 23 | python3-json \ |
| 24 | python3-netserver \ |
| 25 | python3-setuptools \ |
| 26 | python3-unixadmin \ |
| 27 | python3-xmlrpc \ |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 28 | python3-pickle \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |