blob: e122a907cd6dc329e6cbb1ae3b10bf98ac68e2ca [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPLv2.1 | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
11
Andrew Geissler4b7c1152020-11-30 19:55:29 -060012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch \
14 "
Andrew Geisslerd688a012020-09-18 13:36:00 -050015SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e"
16S = "${WORKDIR}/git"
17
18DEPENDS_append_libc-musl = " libucontext"
19XCFLAGS = "-pthread"
20XCFLAGS_append_libc-musl = " -lucontext"
21
22EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
23
24do_install () {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
26}