Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | DESCRIPTION = "IMA/EVM control utility" |
| 2 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS += "openssl attr keyutils" |
| 6 | |
| 7 | DEPENDS_class-native += "openssl-native keyutils-native" |
| 8 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | PV = "1.2.1+git${SRCPV}" |
| 10 | SRCREV = "3eab1f93b634249c1720f65fcb495b1996f0256e" |
| 11 | SRC_URI = "git://git.code.sf.net/p/linux-ima/ima-evm-utils;branch=ima-evm-utils-1.2.y" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 12 | |
| 13 | # Documentation depends on asciidoc, which we do not have, so |
| 14 | # do not build documentation. |
| 15 | SRC_URI += "file://disable-doc-creation.patch" |
| 16 | |
| 17 | # Workaround for upstream incompatibility with older Linux distros. |
| 18 | # Relevant for us when compiling ima-evm-utils-native. |
| 19 | SRC_URI += "file://evmctl.c-do-not-depend-on-xattr.h-with-IMA-defines.patch" |
| 20 | |
| 21 | # Required for xargs with more than one path as argument (better for performance). |
| 22 | SRC_URI += "file://command-line-apply-operation-to-all-paths.patch" |
| 23 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit pkgconfig autotools |
| 27 | |
| 28 | EXTRA_OECONF_append_class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}" |
| 29 | |
| 30 | # blkid is called by evmctl when creating evm checksums. |
| 31 | # This is less useful when signing files on the build host, |
| 32 | # so disable it when compiling on the host. |
| 33 | RDEPENDS_${PN}_append_class-target = " util-linux-blkid libcrypto attr libattr keyutils" |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |