Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework" |
| 2 | LICENSE = "GPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | intltool-native \ |
| 7 | babl \ |
| 8 | glib-2.0 \ |
| 9 | cairo \ |
| 10 | expat \ |
| 11 | zlib \ |
| 12 | \ |
| 13 | json-glib \ |
| 14 | " |
| 15 | |
| 16 | GNOMEBASEBUILDCLASS = "meson" |
| 17 | |
| 18 | inherit features_check gnomebase vala gobject-introspection |
| 19 | |
| 20 | REQUIRED_DISTRO_FEATURES = "x11" |
| 21 | |
| 22 | SHPV = "${@gnome_verdir("${PV}")}" |
| 23 | |
| 24 | SRC_URI = "https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz" |
| 25 | SRC_URI[sha256sum] = "ef63f0bca5b431c6119addd834ca7fbb507c900c4861c57b3667b6f4ccfcaaaa" |
| 26 | |
| 27 | PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg pango poppler sdl2" |
| 28 | PACKAGECONFIG:class-native = "libpng librsvg" |
| 29 | |
| 30 | PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper" |
| 31 | PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2" |
| 32 | PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz" |
| 33 | PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg" |
| 34 | PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms" |
| 35 | PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav" |
| 36 | PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng" |
| 37 | PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw" |
| 38 | PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg" |
| 39 | PACKAGECONFIG[pango] = "-Dpango=enabled -Dpangocairo=enabled,-Dpango=disabled -Dpangocairo=disabled,pango" |
| 40 | PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler" |
| 41 | PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl" |
| 42 | PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2" |
| 43 | PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff" |
| 44 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp" |
| 45 | |
| 46 | # There are a couple of non-symlink .so files installed into libdir, which need to go into main package |
| 47 | FILES:${PN} += " \ |
| 48 | ${libdir}/*.so \ |
| 49 | ${libdir}/gegl-${SHPV}/*.json \ |
| 50 | ${libdir}/gegl-${SHPV}/*.so \ |
| 51 | " |
| 52 | FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}" |
| 53 | |
| 54 | # Fails to build with thumb-1 (qemuarm) |
| 55 | # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process': |
| 56 | # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 |
| 57 | ARM_INSTRUCTION_SET = "arm" |
| 58 | |
| 59 | BBCLASSEXTEND = "native" |