Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "GNOME Settings" |
| 2 | DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | |
| 8 | inherit gnomebase gsettings gettext vala upstream-version-is-even bash-completion features_check |
| 9 | |
| 10 | DEPENDS = " \ |
| 11 | gdk-pixbuf-native \ |
| 12 | colord-gtk \ |
| 13 | udisks2 \ |
| 14 | upower \ |
| 15 | polkit \ |
| 16 | pulseaudio \ |
| 17 | accountsservice \ |
| 18 | samba \ |
| 19 | gsettings-desktop-schemas \ |
| 20 | gnome-settings-daemon \ |
| 21 | gnome-desktop \ |
| 22 | gnome-online-accounts \ |
| 23 | libnma \ |
| 24 | gnome-bluetooth \ |
| 25 | grilo \ |
| 26 | libgtop \ |
| 27 | gsound \ |
| 28 | libpwquality \ |
| 29 | libhandy \ |
| 30 | " |
| 31 | |
| 32 | REQUIRED_DISTRO_FEATURES += "polkit pulseaudio systemd x11" |
| 33 | |
| 34 | SRC_URI[archive.sha256sum] = "8271fc6b33ec2418a578304dd3e57d665f0d7cc706a99a97be419848618fe248" |
| 35 | SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch" |
| 36 | SRC_URI += " file://0001-meson-drop-unused-argument-for-i18n.merge_file.patch" |
| 37 | |
| 38 | PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}" |
| 39 | PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus" |
| 40 | PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland" |
| 41 | |
| 42 | # Once we have (lib)cheese we can make cheese a PACKAGECONFIG |
| 43 | EXTRA_OEMESON = " \ |
| 44 | -Doe_sysroot=${STAGING_DIR_HOST} \ |
| 45 | -Dcheese=false \ |
| 46 | " |
| 47 | |
| 48 | do_install:append() { |
| 49 | # If polkit is setup fixup permissions and ownership |
| 50 | if [ -d ${D}${datadir}/polkit-1/rules.d ]; then |
| 51 | chmod 700 ${D}${datadir}/polkit-1/rules.d |
| 52 | chown polkitd:root ${D}${datadir}/polkit-1/rules.d |
| 53 | fi |
| 54 | } |
| 55 | |
| 56 | FILES:${PN} += " \ |
| 57 | ${datadir}/dbus-1 \ |
| 58 | ${datadir}/gnome-shell \ |
| 59 | ${datadir}/metainfo \ |
| 60 | " |
| 61 | |
| 62 | FILES:${PN}-dev += "${datadir}/gettext" |
| 63 | |
| 64 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |