Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library" |
| 5 | HOMEPAGE = "https://github.com/graeme-hill/crossguid" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68" |
| 8 | DEPENDS += "util-linux" |
| 9 | |
| 10 | SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 11 | SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | do_install() { |
| 18 | install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a |
| 19 | install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp |
| 20 | } |