blob: 6b829811f80c57b73a0f0b6313e118e1df384d91 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
9SRC_URI[sha256sum] = "cb6aef731bf708a7727ab6cde8df87f0281b1427d41e65d62d4b68934fa54e97"
10
11RDEPENDS:${PN} = "\
12 ${PYTHON_PN}-setuptools \
13 ${PYTHON_PN}-jedi \
14 ${PYTHON_PN}-decorator \
15 ${PYTHON_PN}-pickleshare \
16 ${PYTHON_PN}-traitlets \
17 ${PYTHON_PN}-prompt-toolkit \
18 ${PYTHON_PN}-pygments \
19 ${PYTHON_PN}-backcall \
20 ${PYTHON_PN}-pydoc \
21 ${PYTHON_PN}-debugger \
22 ${PYTHON_PN}-pexpect \
23 ${PYTHON_PN}-unixadmin \
24 ${PYTHON_PN}-misc \
25 ${PYTHON_PN}-sqlite3 \
26"
27
28inherit setuptools3 pypi