Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ad081a0aede51e89f8da13333a8fb849" |
| 7 | |
| 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=9.0.x;protocol=https \ |
| 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
| 11 | " |
| 12 | SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8" |
| 13 | |
| 14 | inherit setuptools3 |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | zlib \ |
| 18 | jpeg \ |
| 19 | tiff \ |
| 20 | freetype \ |
| 21 | lcms \ |
| 22 | openjpeg \ |
| 23 | " |
| 24 | |
| 25 | RDEPENDS:${PN} += " \ |
| 26 | ${PYTHON_PN}-misc \ |
| 27 | ${PYTHON_PN}-logging \ |
| 28 | ${PYTHON_PN}-numbers \ |
| 29 | " |
| 30 | |
| 31 | CVE_PRODUCT = "pillow" |
| 32 | |
| 33 | S = "${WORKDIR}/git" |
| 34 | |
| 35 | RPROVIDES:${PN} += "python3-imaging" |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |