Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "CSS selector library for python-beautifulsoup4" |
| 2 | HOMEPAGE = "https://github.com/facelessuser/soupsieve" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=33c3a77def9b3ad83e01c65bdcc1af67" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS:${PN} += "\ |
| 16 | ${PYTHON_PN}-beautifulsoup4 \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN}-ptest += " \ |
| 20 | ${PYTHON_PN}-pytest \ |
| 21 | ${PYTHON_PN}-beautifulsoup4 \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |