Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "Supervisor: A Process Control System" |
| 2 | DESCRIPTION = "\ |
| 3 | Supervisor is a client/server system that allows its users \ |
| 4 | to monitorand control a number of processes on UNIX-like \ |
| 5 | operating systems." |
| 6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" |
| 7 | LICENSE = "BSD-4-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "40dc582ce1eec631c3df79420b187a6da276bbd68a4ec0a8f1f123ea616b97a2" |
| 11 | |
| 12 | PYPI_PACKAGE = "supervisor" |
| 13 | inherit pypi systemd setuptools3 |
| 14 | RDEPENDS:${PN} = "\ |
| 15 | ${PYTHON_PN}-meld3 \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI += "file://supervisord.conf \ |
| 19 | file://supervisor.service \ |
| 20 | " |
| 21 | SYSTEMD_SERVICE:${PN} = "supervisor.service" |
| 22 | |
| 23 | do_install:append() { |
| 24 | install -d ${D}${sysconfdir}/supervisor |
| 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | |
| 27 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor |
| 28 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} |
| 29 | } |