Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "WebKit based web browser for GNOME" |
| 2 | DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \ |
| 3 | It provides a simple and easy-to-use internet browsing experience." |
| 4 | HOMEPAGE = "https://wiki.gnome.org/Apps/Web" |
| 5 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany" |
| 6 | LICENSE = "GPLv3+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
| 9 | DEPENDS = " \ |
| 10 | webkitgtk \ |
| 11 | gcr \ |
| 12 | gsettings-desktop-schemas \ |
| 13 | nettle \ |
| 14 | json-glib \ |
| 15 | libarchive \ |
| 16 | libdazzle \ |
| 17 | libhandy \ |
| 18 | glib-2.0-native \ |
| 19 | " |
| 20 | |
| 21 | GNOMEBASEBUILDCLASS = "meson" |
| 22 | inherit gnomebase gsettings features_check gettext mime-xdg |
| 23 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 24 | |
| 25 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
| 26 | file://0002-help-meson.build-disable-the-use-of-yelp.patch \ |
| 27 | file://bfbb5f7bab38301d8a4a444173acdae8d9692146.patch \ |
| 28 | file://migrator.patch \ |
| 29 | file://distributor.patch \ |
| 30 | " |
| 31 | SRC_URI[archive.sha256sum] = "ba01268ee54f318dfdac2e01eba38a3fc96940c1cbf640ed2613ae29f8bcb9ad" |
| 32 | |
| 33 | PACKAGECONFIG_SOUP ?= "soup2" |
| 34 | PACKAGECONFIG ??= "${PACKAGECONFIG_SOUP}" |
| 35 | |
| 36 | # Developer mode enables debugging |
| 37 | PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false" |
| 38 | PACKAGECONFIG[soup2] = "-Dsoup2=enabled,-Dsoup2=disabled,libsoup-2.4,,,soup3" |
| 39 | PACKAGECONFIG[soup3] = ",,libsoup,,,soup2" |
| 40 | PACKAGECONFIG[libportal] = "-Dlibportal=enabled,-Dlibportal=disabled,libportal" |
| 41 | |
| 42 | FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo" |
| 43 | RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas" |