Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 3 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a" |
| 7 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 8 | SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 9 | file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 10 | file://0001-framework-do-not-mix-plain-and-keyword-target_link_l.patch \ |
| 11 | file://0001-framework-core-Add-explicit-static_cast-from-vk-Buff.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 12 | file://debugfix.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | UPSTREAM_CHECK_COMMITS = "1" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 16 | SRCREV = "ae6e4a3712cebde49a29e5996a3bd2f403566890" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 17 | |
| 18 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 22 | COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 23 | |
| 24 | inherit cmake features_check |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | FILES:${PN} += "${datadir}" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 27 | |
| 28 | # |
| 29 | # There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths |
| 30 | # used for logging with LOGE in the code. We need to make this match the value we use |
| 31 | # in the debug source remapping from CFLAGS |
| 32 | # |
| 33 | EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/" |
| 34 | # Binaries built with PCH enabled don't appear reproducible, differing results were seen |
| 35 | # from some builds depending on the point the PCH was compiled. Disable it to be |
| 36 | # deterministic |
| 37 | EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | |
| 39 | # This needs to be specified explicitly to avoid xcb/xlib dependencies |
| 40 | EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D" |