Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Test runner for GNOME-style installed tests" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Runner provides an execution harness for GNOME installed tests. \ |
| 3 | These tests are useful for verifying the functionality of software as \ |
| 4 | installed and packaged, and complement rather than replace build-time \ |
| 5 | ('make check') tests." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | HOMEPAGE = "https://wiki.gnome.org/GnomeGoals/InstalledTests" |
| 7 | LICENSE = "LGPLv2+" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ |
| 10 | file://src/gnome-desktop-testing-runner.c;beginline=1;endline=20;md5=7ef3ad9da2ffcf7707dc11151fe007f4" |
| 11 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 12 | SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-desktop-testing.git;protocol=http;branch=master \ |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 13 | file://0001-fix-non-literal-format-string-issue-with-clang.patch \ |
| 14 | " |
| 15 | SRCREV = "e346cd4ed2e2102c9b195b614f3c642d23f5f6e7" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | DEPENDS = "glib-2.0" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 24 | PACKAGECONFIG[systemd] = ",,systemd" |