Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "Library for reading extended image information (EXIF) from JPEG files" |
| 2 | DESCRIPTION = "libexif is a library for parsing, editing, and saving EXIF data. It is \ |
| 3 | intended to replace lots of redundant implementations in command-line \ |
| 4 | utilities and programs with GUIs." |
| 5 | HOMEPAGE = "https://libexif.github.io/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad" |
| 9 | |
| 10 | def version_underscore(v): |
| 11 | return "_".join(v.split(".")) |
| 12 | |
| 13 | SRC_URI = "https://github.com/libexif/libexif/releases/download/v${PV}/libexif-${PV}.tar.bz2 \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[sha256sum] = "d47564c433b733d83b6704c70477e0a4067811d184ec565258ac563d8223f6ae" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/" |
| 19 | |
| 20 | inherit autotools gettext |
| 21 | |
| 22 | EXTRA_OECONF += "--disable-docs" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |