Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | DEPENDS = "file" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
| 10 | SRC_URI[sha256sum] = "9278907a6f571b391aab9644fd646a5108ed97311ec66f6359cebbedb0a4e3bb" |
| 11 | |
| 12 | inherit autotools lib_package pkgconfig gettext |
| 13 | |
| 14 | CFLAGS += "-pthread -D_REENTRANT" |
| 15 | |
| 16 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 17 | |
| 18 | PACKAGECONFIG ?= "curl https" |
| 19 | PACKAGECONFIG:append:class-target = "\ |
| 20 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 21 | " |
| 22 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 23 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 24 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 25 | |
| 26 | do_compile:append() { |
| 27 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |