Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "Setuptools extension for CalVer package versions" |
| 2 | HOMEPAGE = "https://github.com/di/calver" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | git://github.com/di/calver;branch=master;protocol=https \ |
| 8 | file://run-ptest \ |
| 9 | file://0001-setup.py-hard-code-version.patch \ |
| 10 | " |
| 11 | SRCREV = "3268d8acf2c345f32a1c5f08ba25dc67f76cca81" |
| 12 | |
| 13 | inherit python_setuptools_build_meta ptest |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pretend \ |
| 19 | ${PYTHON_PN}-pytest \ |
| 20 | ${PYTHON_PN}-unittest-automake-output \ |
| 21 | " |
| 22 | |
| 23 | do_install_ptest() { |
| 24 | install -d ${D}${PTEST_PATH}/tests |
| 25 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |