Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | HOMEPAGE = "https://pypi.org/project/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT & Apache-2.0 & MPL-2.0 & LGPL-2.1-only & BSD-3-Clause & PSF-2.0 & BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030 \ |
| 6 | file://src/pip/_vendor/cachecontrol/LICENSE.txt;md5=6572692148079ebbbd800be4b9f36c6d \ |
| 7 | file://src/pip/_vendor/certifi/LICENSE;md5=3c2b7404369c587c3559afb604fce2f2 \ |
| 8 | file://src/pip/_vendor/chardet/LICENSE;md5=4fbd65380cdd255951079008b364516c \ |
| 9 | file://src/pip/_vendor/colorama/LICENSE.txt;md5=b4936429a56a652b84c5c01280dcaa26 \ |
| 10 | file://src/pip/_vendor/distlib/LICENSE.txt;md5=f6a11430d5cd6e2cd3832ee94f22ddfc \ |
| 11 | file://src/pip/_vendor/distro/LICENSE;md5=d2794c0df5b907fdace235a619d80314 \ |
| 12 | file://src/pip/_vendor/idna/LICENSE.md;md5=239668a7c6066d9e0c5382e9c8c6c0e1 \ |
| 13 | file://src/pip/_vendor/msgpack/COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751 \ |
| 14 | file://src/pip/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \ |
| 15 | file://src/pip/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 16 | file://src/pip/_vendor/pkg_resources/LICENSE;md5=141643e11c48898150daa83802dbc65f \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 17 | file://src/pip/_vendor/platformdirs/LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a \ |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 18 | file://src/pip/_vendor/pygments/LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592 \ |
| 19 | file://src/pip/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 20 | file://src/pip/_vendor/pyproject_hooks/LICENSE;md5=aad69c93f605003e3342b174d9b0708c \ |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 21 | file://src/pip/_vendor/requests/LICENSE;md5=34400b68072d710fecd0a2940a0d1658 \ |
| 22 | file://src/pip/_vendor/resolvelib/LICENSE;md5=78e1c0248051c32a38a7f820c30bd7a5 \ |
| 23 | file://src/pip/_vendor/rich/LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303 \ |
| 24 | file://src/pip/_vendor/six.LICENSE;md5=43cfc9e4ac0e377acfb9b76f56b8415d \ |
| 25 | file://src/pip/_vendor/tenacity/LICENSE;md5=175792518e4ac015ab6696d16c4f607e \ |
| 26 | file://src/pip/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 27 | file://src/pip/_vendor/typing_extensions.LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2 \ |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 28 | file://src/pip/_vendor/urllib3/LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c \ |
| 29 | file://src/pip/_vendor/webencodings/LICENSE;md5=81fb24cd7823cce23b69f721993dce4d \ |
| 30 | " |
| 31 | |
| 32 | inherit pypi python_setuptools_build_meta |
| 33 | |
| 34 | SRC_URI += "file://no_shebang_mangling.patch" |
| 35 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 36 | SRC_URI[sha256sum] = "fb0bd5435b3200c602b5bf61d2d43c2f13c02e29c1707567ae7fbc514eb9faf2" |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 37 | |
| 38 | do_install:append() { |
| 39 | rm -f ${D}/${bindir}/pip |
| 40 | } |
| 41 | |
| 42 | RDEPENDS:${PN} = "\ |
| 43 | python3-compile \ |
| 44 | python3-io \ |
| 45 | python3-html \ |
| 46 | python3-json \ |
| 47 | python3-multiprocessing \ |
| 48 | python3-netserver \ |
| 49 | python3-setuptools \ |
| 50 | python3-unixadmin \ |
| 51 | python3-xmlrpc \ |
| 52 | python3-pickle \ |
| 53 | python3-distutils \ |
| 54 | python3-image \ |
| 55 | " |
| 56 | |
| 57 | BBCLASSEXTEND = "native nativesdk" |
| 58 | |
| 59 | # This used to use the bootstrap install which didn't compile. Until we bump the |
| 60 | # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| 61 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |