Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Try::Tiny - Minimal try/catch with proper preservation of $@" |
| 2 | DESCRIPTION = "This module provides bare bones try/catch/finally statements \ |
| 3 | that are designed to minimize common mistakes with eval blocks, and NOTHING \ |
| 4 | else." |
| 5 | HOMEPAGE = "https://github.com/p5sagit/Try-Tiny" |
| 6 | BUGTRACKER = "https://rt.cpan.org/Public/Dist/Display.html?Name=Try-Tiny" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "MIT" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENCE;md5=5dc332c2d4aade55f5db244681000091" |
| 11 | |
| 12 | SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Try-Tiny-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "3300d31d8a4075b26d8f46ce864a1d913e0e8467ceeba6655d5d2b2e206c11be" |
| 15 | |
| 16 | S = "${WORKDIR}/Try-Tiny-${PV}" |
| 17 | |
| 18 | inherit cpan ptest-perl |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | perl-module-carp \ |
| 22 | perl-module-constant \ |
| 23 | perl-module-exporter \ |
| 24 | " |
| 25 | RRECOMMENDS:${PN} += "\ |
| 26 | perl-module-sub-util \ |
| 27 | " |
| 28 | RDEPENDS:${PN}-ptest += "\ |
| 29 | perl-module-extutils-makemaker \ |
| 30 | perl-module-extutils-mm-unix \ |
| 31 | perl-module-file-spec \ |
| 32 | perl-module-if \ |
| 33 | perl-module-test-more \ |
| 34 | " |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |