blob: 0debba48d23651719dbef3e34200a72d35cc52a0 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05006SRC_URI[md5sum] = "cf3ca19873fa9e7f6162296cf6bae419"
7SRC_URI[sha256sum] = "25c95d2ac813909f813c93fde734b6e44406d1477a9faef7c915ff37d39c0a8c"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "prompt_toolkit"
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-terminal \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-wcwidth \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-shell \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021 ${PYTHON_PN}-image \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022"
23
24BBCLASSEXTEND = "native nativesdk"