Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap" |
| 2 | DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \ |
| 3 | bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \ |
| 4 | and copying files using the block map. The idea is that large file containing \ |
| 5 | unused blocks, like raw system image files, can be copied or flashed a lot \ |
| 6 | faster with bmaptool than with traditional tools like "dd" or "cp"." |
| 7 | HOMEPAGE = "https://github.com/01org/bmap-tools" |
| 8 | SECTION = "console/utils" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
| 12 | SRC_URI = "git://github.com/intel/${BPN}" |
| 13 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 14 | SRCREV = "a17f0e3ff8669dd3b1c44a741ae4f8162155faed" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | PV .= "+git${SRCPV}" |
| 17 | |
| 18 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 19 | |
| 20 | RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six" |
| 21 | |
| 22 | inherit python3native |
| 23 | inherit setuptools3 |
| 24 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame^] | 25 | BBCLASSEXTEND = "native nativesdk" |