blob: c7c1ad1eca2c2345c0ac906baeca587232075a84 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
2DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
3It is written using the Boost Spirit parser generator. If you are \
4already using Boost, you can use JSON Spirit without any additional \
5dependencies."
6HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
7SECTION = "libs"
8PRIORITY = "optional"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
11
12SRC_URI = "file://json_spirit_v${PV}.zip \
13 file://0001-Adjust-the-cmake-files.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0001-Link-to-libatomic.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015"
16
17S = "${WORKDIR}/json_spirit_v${PV}"
18
19DEPENDS = "boost"
20
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021inherit cmake
22
23FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake"
24
25BBCLASSEXTEND = "nativesdk"