Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Development package for building Applications that use numa" |
| 2 | HOMEPAGE = "http://oss.sgi.com/projects/libnuma/" |
| 3 | DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \ |
| 4 | to run other programs with a specific NUMA policy and a libnuma to do \ |
| 5 | allocations with NUMA policy in applications." |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 7 | SECTION = "apps" |
| 8 | |
| 9 | inherit autotools-brokensep ptest |
| 10 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=9f34c3af4ed6f3f5df0da5f3c0835a43" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 12 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 13 | SRCREV = "10285f1a1bad49306839b2c463936460b604e3ea" |
| 14 | PV = "2.0.16" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 15 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | SRC_URI = "git://github.com/numactl/numactl;branch=master;protocol=https \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 17 | file://Fix-the-test-output-format.patch \ |
| 18 | file://Makefile \ |
| 19 | file://run-ptest \ |
| 20 | file://0001-define-run-test-target.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | file://0001-configure-Check-for-largefile-support.patch \ |
| 22 | file://0002-shm.c-Replace-stat64-fstat64-ftruncate64mmap64-with-.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | LDFLAGS:append:riscv64 = " -latomic" |
| 28 | LDFLAGS:append:riscv32 = " -latomic" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 29 | |
| 30 | do_install() { |
| 31 | oe_runmake DESTDIR=${D} prefix=${D}/usr install |
| 32 | #remove the empty man2 directory |
| 33 | rm -r ${D}${mandir}/man2 |
| 34 | } |
| 35 | |
| 36 | do_compile_ptest() { |
| 37 | oe_runmake test |
| 38 | } |
| 39 | |
| 40 | do_install_ptest() { |
| 41 | #install tests binaries |
| 42 | local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \ |
| 43 | mynode nodemap node-parse pagesize prefered randmap realloc_test \ |
| 44 | tbitmap tshared" |
| 45 | |
| 46 | [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test |
| 47 | for i in $test_binaries; do |
| 48 | install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test |
| 49 | done |
| 50 | |
| 51 | local test_scripts="checktopology checkaffinity printcpu regress regress2 \ |
| 52 | shmtest runltp bind_range" |
| 53 | for i in $test_scripts; do |
| 54 | install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test |
| 55 | done |
| 56 | |
| 57 | install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/ |
| 58 | install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/ |
| 59 | } |
| 60 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 61 | RDEPENDS:${PN}-ptest = "bash" |