blob: 71b5431400b5045635aec38964860368d09cbd7f [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Setuptools extension for CalVer package versions"
2HOMEPAGE = "https://github.com/di/calver"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI = " \
7 git://github.com/di/calver;branch=master;protocol=https \
8 file://run-ptest \
9 file://0001-setup.py-hard-code-version.patch \
10"
11SRCREV = "3268d8acf2c345f32a1c5f08ba25dc67f76cca81"
12
13inherit python_setuptools_build_meta ptest
14
15S = "${WORKDIR}/git"
16
17RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060018 python3-pretend \
19 python3-pytest \
20 python3-unittest-automake-output \
Andrew Geissler3eeda902023-05-19 10:14:02 -050021"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests ${D}${PTEST_PATH}/
26}
27
28BBCLASSEXTEND = "native nativesdk"