Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Plugin and hook calling mechanisms for python" |
| 2 | HOMEPAGE = "https://github.com/pytest-dev/pluggy" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2" |
| 5 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "8c85c2876142a764e5b7548e7d9a0e0ddb46f5185161049a79b7e974454223be" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 7 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 8 | DEPENDS += "python3-setuptools-scm-native" |
| 9 | RDEPENDS:${PN} += "python3-importlib-metadata \ |
| 10 | python3-more-itertools \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 11 | " |
| 12 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 13 | inherit pypi ptest python_setuptools_build_meta |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://run-ptest \ |
| 17 | " |
| 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 20 | python3-pytest \ |
| 21 | python3-unittest-automake-output \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/testing |
| 26 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/ |
| 27 | } |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |