Vijay Khemka | 45269ba | 2018-12-13 11:07:06 -0800 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := "${THISDIR}/files:" |
| 2 | |
| 3 | inherit systemd |
| 4 | |
| 5 | S = "${WORKDIR}/" |
| 6 | |
| 7 | SRC_URI = "file://setup_gpio.sh \ |
| 8 | file://power-util \ |
| 9 | file://host-gpio.service \ |
| 10 | file://host-poweroff.service \ |
| 11 | file://host-poweron.service" |
| 12 | |
| 13 | DEPENDS = "systemd" |
| 14 | RDEPENDS_${PN} = "bash" |
| 15 | |
| 16 | SYSTEMD_PACKAGES = "${PN}" |
| 17 | SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service" |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}/usr/sbin |
| 21 | install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/ |
| 22 | install -m 0755 ${S}power-util ${D}/${sbindir}/ |
| 23 | } |