blob: 37fa835886f7b837d89e65aaf5a3af7ad547003d [file] [log] [blame]
Vijay Khemka45269ba2018-12-13 11:07:06 -08001FILESEXTRAPATHS_append := "${THISDIR}/files:"
2
3inherit systemd
4
5S = "${WORKDIR}/"
6
7SRC_URI = "file://setup_gpio.sh \
8 file://power-util \
9 file://host-gpio.service \
10 file://host-poweroff.service \
11 file://host-poweron.service"
12
13DEPENDS = "systemd"
14RDEPENDS_${PN} = "bash"
15
16SYSTEMD_PACKAGES = "${PN}"
17SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
18
19do_install() {
20 install -d ${D}/usr/sbin
21 install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/
22 install -m 0755 ${S}power-util ${D}/${sbindir}/
23}