blob: 2be6beacbc45a709c8f735e0cd46cc0246b58c06 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Tracker miners and metadata extractors"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 intltool-native \
10 libseccomp \
11 tracker \
12 zlib \
13"
14
15
16inherit gnomebase gsettings gobject-introspection vala bash-completion features_check
17
18SRC_URI:append = " \
19 file://0001-fix-reproducibility.patch \
20 file://0001-Set-header-file-to-a-fixed-path-instead-of-a-host-pa.patch \
21"
22SRC_URI[archive.sha256sum] = "0ad722f3d532c21d757cf488f942960679ea8f457925efa97656ed4c9e9ba4ff"
23
24# gobject-introspection is mandatory and cannot be configured
25REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
26GIR_MESON_OPTION = ""
27VALA_MESON_OPTION = ""
28
29PACKAGECONFIG ??= " \
30 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg", "", d)} \
31 gexiv2 \
32 gstreamer \
33 icu \
34 libexif \
35 libgsf \
36 jpeg \
37 pdf \
38 png \
39 tiff \
40 raw \
41 xml \
42 ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)} \
43 battery \
44 networkmanager \
45"
46
47PACKAGECONFIG[battery] = "-Dbattery_detection=upower,-Dbattery_detection=none,upower"
48PACKAGECONFIG[cue] = "-Dcue=enabled,-Dcue=disabled,libcue"
49PACKAGECONFIG[ffmpeg] = "-Dgeneric_media_extractor=libav,,ffmpeg"
50PACKAGECONFIG[gexiv2] = ",,gexiv2"
51PACKAGECONFIG[gstreamer] = "-Dgeneric_media_extractor=gstreamer,,gstreamer1.0 gstreamer1.0-plugins-base"
52PACKAGECONFIG[gupnp] = "-Dgstreamer_backend=gupnp,,gupnp-dlna"
53PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib"
54PACKAGECONFIG[icu] = "-Dcharset_detection=icu,,icu"
55PACKAGECONFIG[iso] = "-Diso=enabled,-Diso=disabled,libosinfo"
56PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
57PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif"
58PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf"
59PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler"
60PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng"
61PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff"
62PACKAGECONFIG[raw] = "-Draw=enabled,-Draw=disabled,libraw"
63PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2"
64PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanager"
65
66# For security reasons it is strongly recommended to set add meta-security in
67# your layers and 'libseccomp' to PACKAGECONFIG".
68PACKAGECONFIG[seccomp] = "-Dseccomp=true,-Dseccomp=false,libseccomp"
69# not yet in meta-gnome
70PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss"
71
72EXTRA_OEMESON += " \
73 -Dman=false \
74 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
75 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
76"
77
78FILES:${PN} += " \
79 ${datadir}/dbus-1 \
80 ${datadir}/tracker3-miners \
81 ${libdir}/tracker-miners-3.0 \
82 ${systemd_user_unitdir} \
83"