Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access." |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libcdio/" |
| 3 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-3.0-or-later" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2 \ |
| 8 | file://0001-Fix-a-few-Werror-format-security-errors-with-mvprint.patch \ |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 9 | file://Drop-LIBCDIO_SOURCE_PATH-by-dropping-STRIP_FROM_PATH.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | |
| 12 | SRC_URI[md5sum] = "aa7629e8f73662a762f64c444b901055" |
| 13 | SRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b" |
| 14 | |
| 15 | inherit autotools pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ??= "cdda-player" |
| 18 | PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses" |
| 19 | PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb" |
| 20 | PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager" |
| 21 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 22 | # add -D_LARGEFILE64_SOURCE for 32bit targets |
| 23 | CFLAGS += "${@['-D_LARGEFILE64_SOURCE',''][d.getVar('SITEINFO_BITS') != '32']}" |
| 24 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | PACKAGES += "${PN}-utils" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN} = "${libdir}/${BPN}${SOLIB}" |
| 28 | FILES:${PN}-utils = "${bindir}/*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | |
| 30 | python libcdio_split_packages() { |
| 31 | libdir = d.expand('${libdir}') |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 32 | do_split_packages(d, libdir, r'^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True) |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 33 | } |
| 34 | |
| 35 | PACKAGESPLITFUNCS =+ "libcdio_split_packages" |