Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "An OpenSSL provider that allows direct interfacing with pkcs11 drivers" |
| 2 | DESCRIPTION = "\ |
| 3 | This is an Openssl 3.x provider to access Hardware or Software Tokens using \ |
| 4 | the PKCS#11 Cryptographic Token Interface\ |
| 5 | \ |
| 6 | This code targets version 3.1 of the interface but should be backwards \ |
| 7 | compatible to previous versions as well.\ |
| 8 | " |
| 9 | HOMEPAGE = "https://github.com/latchset/pkcs11-provider" |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "Apache-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=b53b787444a60266932bd270d1cf2d45" |
| 13 | DEPENDS = "\ |
| 14 | autoconf-archive \ |
| 15 | openssl \ |
| 16 | p11-kit \ |
| 17 | " |
| 18 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | SRCREV = "58040b4e32975cc1d7f39e424ee7b0097cd11311" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 20 | |
| 21 | SRC_URI = "git://github.com/latchset/${BPN}.git;branch=main;protocol=https" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools pkgconfig |
| 26 | |
| 27 | FILES:${PN} += "${libdir}/ossl-modules/pkcs11.so" |