blob: 816ee967c180c9335d7d8fbd4044fa3170ac53b4 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "An OpenSSL provider that allows direct interfacing with pkcs11 drivers"
2DESCRIPTION = "\
3This is an Openssl 3.x provider to access Hardware or Software Tokens using \
4the PKCS#11 Cryptographic Token Interface\
5\
6This code targets version 3.1 of the interface but should be backwards \
7compatible to previous versions as well.\
8"
9HOMEPAGE = "https://github.com/latchset/pkcs11-provider"
10SECTION = "libs"
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b53b787444a60266932bd270d1cf2d45"
13DEPENDS = "\
14 autoconf-archive \
15 openssl \
16 p11-kit \
17"
18
Patrick Williams73bd93f2024-02-20 08:07:48 -060019SRCREV = "58040b4e32975cc1d7f39e424ee7b0097cd11311"
Patrick Williams169d7bc2024-01-05 11:33:25 -060020
21SRC_URI = "git://github.com/latchset/${BPN}.git;branch=main;protocol=https"
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig
26
27FILES:${PN} += "${libdir}/ossl-modules/pkcs11.so"