blob: ad07b3b082f25aba14618a13be02a293916efa96 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A small Python module for determining appropriate + platform-specific dirs, e.g. a user data dir."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=31625363c45eb0c67c630a2f73e438e4"
4
5SRC_URI += " \
6 file://run-ptest \
7"
8
Andrew Geissler2ee498a2020-05-29 15:52:06 -05009SRC_URI[md5sum] = "d6bca12613174185dd9abc8a29f4f012"
10SRC_URI[sha256sum] = "7d5d0167b2b1ba821647616af46a749d1c653740dd0d2415100fe26e27afdf41"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12inherit pypi setuptools3 ptest
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-pytest \
16 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/test
21 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
22}
Patrick Williams8e7b46e2023-05-01 14:19:06 -050023
24BBCLASSEXTEND = "native nativesdk"