Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "asyncio-compatible timeout context manager" |
| 2 | DESCRIPTION = "\ |
| 3 | The context manager is useful in cases when you want to apply \ |
| 4 | timeout logic around block of code or in cases when asyncio.wait_for() \ |
| 5 | is not suitable. Also it's much faster than asyncio.wait_for() because \ |
| 6 | timeout doesn't create a new task." |
| 7 | HOMEPAGE = "https://github.com/aio-libs/async-timeout" |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fa41f15bb5f23b6d3560c5845eb8d57" |
| 10 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "4640d96be84d82d02ed59ea2b7105a0f7b33abe8703703cd0ab0bf87c427522f" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
| 13 | PYPI_PACKAGE = "async-timeout" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | |
| 16 | RDEPENDS:${PN} = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 17 | python3-asyncio \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | " |