blob: a0454686ee6aa5219240513174ac0468b2294c81 [file] [log] [blame]
Andrew Geisslerd221e032020-07-10 16:13:21 -05001DESCRIPTION = "VCR imitation for python requests"
2HOMEPAGE = "https://github.com/betamaxpy/betamax"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c"
5
6SRC_URI += " \
7 file://run-ptest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05008 file://0001-Drop-ptests-fixtures-and-recorde_modes.patch \
Andrew Geisslerd221e032020-07-10 16:13:21 -05009"
Patrick Williamsb58112e2024-03-07 11:16:36 -060010SRC_URI[sha256sum] = "82316e1679bc6879e3c83318d016b54b7c9225ff08c4462de4813e22038d5f94"
Andrew Geisslerd221e032020-07-10 16:13:21 -050011
12inherit pypi setuptools3 ptest
13
Patrick Williams520786c2023-06-25 16:20:36 -050014RDEPENDS:${PN} += " \
15 python3-requests \
16 python3-unittest \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-pytest \
21 python3-unittest-automake-output \
Andrew Geisslerd221e032020-07-10 16:13:21 -050022"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}