blob: 8f2cf4883dd21f3c887a948ff31ae18f4c5e67c7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Fast, simple object-to-object and broadcast signaling."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=42cd19c88fc13d1307a4efd64ee90e4e"
4
5SRC_URI[sha256sum] = "e6820ff6fa4e4d1d8e2747c2283749c3f547e4fee112b98555cdcdae32996182"
6
7inherit pypi python_setuptools_build_meta ptest
8
9SRC_URI += "file://run-ptest"
10
11RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060012 python3-asyncio \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013"
14
15RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-pytest \
17 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}